Skip to content

Tuning FreeBSD for Samba network performance

I’ve already compiled a custom kernel that enables polling. I’m now following http://forums.freebsd.org/showthread.php?t=9187:

in loader.conf:

aio_load=”YES”

Luckily, I had already built samba with AIO support.

In smb.conf:


min receivefile size = 131072
aio read size = 1
aio write size = 1
use sendfile = yes

In rc.conf:

ifconfig_re0=”DHCP polling”

in sysctl.conf:

kern.ipc.maxsockbuf=16777216
kern.ipc.nmbclusters=32768
kern.ipc.somaxconn=32768
kern.maxfiles=65536
kern.maxfilesperproc=32768
kern.maxvnodes=800000
net.inet.tcp.delayed_ack=0
net.inet.tcp.inflight.enable=0
net.inet.tcp.path_mtu_discovery=0
net.inet.tcp.recvbuf_auto=1
net.inet.tcp.recvbuf_inc=524288
net.inet.tcp.recvbuf_max=16777216
net.inet.tcp.recvspace=65536
net.inet.tcp.rfc1323=1
net.inet.tcp.sendbuf_auto=1
net.inet.tcp.sendbuf_inc=524288
net.inet.tcp.sendspace=65536
net.inet.udp.maxdgram=57344
net.inet.udp.recvspace=65536
net.local.stream.recvspace=65536
net.inet.tcp.sendbuf_max=16777216
net.inet.tcp.mssdflt=1460

See also http://www.psc.edu/networking/projects/tcptune/.

Nuts. Still topping out at 11 MB/s. Wonder if it’s the disk, or if it’s the Windows 7 machine that I’m using to initiate the Samba transfer for testing.

Be the first to like.

Post a Comment

Your email is never published nor shared. Required fields are marked *
*
*